perl-Git Kurulum Hatası

Terminalde #yum update yazıyorsunuz ancak güncelleme aşağıdaki gibi hata veriyor. Bu hatayı verdiği içinde uzun bir update listesini güncelleyemiyorsunuz. Aslında çözüm çok basit, tabii ne yapacağınızı bilmiyorsanız o zaman basit değil zor oluyor.

// OUTPUT CODE
—> Package git.x86_64 0:1.7.1-9.el6_9 will be installed
–> Processing Dependency: perl-Git = 1.7.1-9.el6_9 for package: git-1.7.1-9.el6_9.x86_64
–> Processing Dependency: perl(Git) for package: git-1.7.1-9.el6_9.x86_64
–> Finished Dependency Resolution
Error: Package: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
Requires: perl-Git = 1.7.1-9.el6_9
Error: Package: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
Requires: perl(Git)
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Bu hata perl-Git kurulması gerektiğini ama kurulamadığını söylüyor diye özetleyebiliriz.

Hatayı görünce yapmanız gereken sadece aşağıdaki komutu çalıştırmak.

yum install perl-Git --disableexcludes=main

perl-Git kurulumu sonrası artık yum update komutunu verdiğinizde hatanın yok olduğunu ve normal olarak güncellemenin devam ettiğini görebilirsiniz. Çünkü gerekli kurulum yapıldı.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.