Wordpress Güvenlik

Netopsiyon Siteleri Yöneticisi
Kullanıcı avatarı
Mesajlar: 42
Kayıt: 20 Tem 2002, 00:00
Konum: Balıkesir

Wordpress Güvenlik

Mesajgönderen Aliosman » 10 Eki 2013, 10:25

Herşeyden önce wordpress son versiyonunu kullanmalısınız. Her yeni sürümde birçok güvenlik açığı kapatılmaktadır. Basit olarak birkaç tane uygulama yaparak güvenliğinizi az da olsa arttırmanıza yararlı olacak aşağıdaki uygulamaları gerçekleştirin.

Eklenti olarak http://wordpress.org/plugins/better-wp-security/ adresindeki eklentiyi kurunuz.

wp-includes güvenliği için .htaccess dosyanıza aşağıdaki kodları ekleyiniz.

Kod: Tümünü seç
RewriteEngine On
RewriteBase /
RewriteRule ^wp-admin/includes/ - [F,L]
RewriteRule !^wp-includes/ - [S=3]
RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
RewriteRule ^wp-includes/theme-compat/ - [F,L]


wp-config.php güvenliği için ise aşağıdaki kodları yine .htaccess dosyasının içine ekleyiniz.

Kod: Tümünü seç
<Files wp-config.php>
order allow,deny
deny from all
</Files>


Son olarak siteniz herşeyiyle hazırsa wp-config.php dosyanızın içerisine aşağıdaki kod ekleyerek (varsa değiştiriniz) dosya düzenlemeyi kapatınız.

Kod: Tümünü seç
define('DISALLOW_FILE_EDIT', true);


Güvenli bloglamalar...
===========================
http://www.netopsiyon.com.tr
===========================

Mesaj: 1+
Kullanıcı avatarı
Mesajlar: 1
Kayıt: 18 Kas 2005, 01:00
Konum: Trabzon/izmir 61-35

Re: Wordpress Güvenlik

Mesajgönderen mavisce » 22 Ara 2013, 15:35

Wordpress e el atmak lazım Dünya bu sistemi kullanıyor biz hala nuke gerçe ben hiç birini kullanmıyorum ama neyse nuke kullananlar bırakın nuke u wordpress e geçin

Dön Wordpress

Kimler çevrimiçi

Bu forumu gezen kullanıcılar: Hiç bir kayıtlı kullanıcı yok ve 0 misafir